LOGITECH WIRELESS TOUCH KEYBOARD K400 LINUX DRIVER

The Fn function key combination buttons do not. This post is to confirm that K does work with Debian and Ubuntu. The touch-pad works, including two-finger scrolling and double-tap gestures, the two-finger scrolling and mouse-buttons however seem somewhat unresponsive at times – probably the same issue as the sticky keys – perhaps the RPi is interfering with the RF signal and it is dropping data packets. Will not respond to PM requests for support — use the forums. I just assumed that it didn’t work with Pi, but now that I know others have it working I’d like to fix my issues.

Uploader: Zololkis
Date Added: 10 March 2013
File Size: 67.93 Mb
Operating Systems: Windows NT/2000/XP/2003/2003/7/8/10 MacOS 10/X
Downloads: 83224
Price: Free* [*Free Regsitration Required]

Unifying Receiver Device Descriptor: Besides the camera, I also bought a very basic computer yesterday equipped with the Logitech K wireless keyboard.

[ubuntu] How to change settings of a Logitech K keyboard?

Yes Ethernet connected to NetGear DG used as a wireless access point which in turn is connected to a powerline plug to the main router Notes: Oh, and it has a terrific range, too. Is anyone else having this issue with this keyboard and Debian squeeze?

This post is to confirm that K does work with Debian and Ubuntu. No software required, OS is irrelevant. The only issue I have is with changing VTs. I finally bought the k, it support two finger swipe for horizontal and vertical scrolling but no more gestures. Never knew you could do that … that works on the K in a mozilla browser … on Puppy linux, even. When I try to reconfigure the keyboard, it comes up as a Generic key, and although there are a lot of logitech keyboards listed the K is not an option I can choose.

  GO 7150M XP DRIVER

Then it suddenly stopped working.

KR keyboard worked perfectly with a Win-7 laptop and shortly also that, once the USB-socket was transported to it, also on a Ubuntu pc, but only k4400 a system reboot, which returned the English layout settings. The same happens with the keyboard, you are writing, it freezes and suddenly all the letters appear.

That keyboard has fewer functions than mine aside from the touch pad. Does anyone know if there any utilities or drivers to control this device? Hopefully somebody will recommend something that works right.

Logitech’s tech support asked me “Is Linux a program you are running on Windows? How to change settings of a Logitech K keyboard?

MODERATORS

But I would be very surprised if it failed to function. Only replace the batteries once in two years. Before I did that, the keyboard and WiFi problems were much worse. I have an HP Elite, which is also wireless and has several built-in dedicated function buttons: Anders Runeson April 13, at Mrsrail April 27, at 6: This one was much more robust, but well, it’s from MS and I have no idea how well it works in Linux.

  GIGAWARE RS232 DRIVER DOWNLOAD

I tried replacing the batteries twice. It works fine assuming you are satisfied with the English keyboard layout.

Email required Address never made public. Did you try the Unifying pairing tools created for debian yet? Functionality was spotty at best; the mouse would stutter and jerk and it would not recognize keystrokes randomly. My setup – Model: Does it work for you? Join Date Oct Beans 2. Nothing in other USB socket. The keyboard and track pad also work in Quake3 although the touch pad is less than ideal for blowing away the baddies.